axisOrderCrossProductsInPlace Method
Form cross products among columns in axisOrder. For axis order ABC:
- form cross product of column A and B, store in C.
- form cross product of column C and A, store in B.
- [A B C] ===> [A B AxB] ===> [A (AxB)xA AxB]
This means that in the final matrix:
- first column is same as original column A.
- second column is linear combination of original A and B (i.e., is in the plane of original A and B).
- third column is perpendicular to first and second columns of both the original and final.
- original column C is overwritten and does not participate in the result.
The final matrix will have 3 orthogonal columns.
axisOrderCrossProductsInPlace(axisOrder: AxisOrder): void
Parameter | Type | Description |
---|---|---|
axisOrder | AxisOrder |
Returns - void
Defined in
- geometry3d/Matrix3d.ts Line 2305
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.