GeodesicPathSolver Class
Algorithm implementation class for computing approximate optimal (shortest) path points.
- Call the static method
createGeodesicPath
to compute path points.
Methods
Name | Description | |
---|---|---|
approximateMinimumLengthSectionArc(ellipsoid: Ellipsoid, angleA: LongitudeLatitudeNumber, angleB: LongitudeLatitudeNumber, numSample: number, normalInterpolationFraction0: number, normalInterpolationFraction1: number): undefined | { minLengthArc: Arc3d, minLengthNormalInterpolationFraction: number } Static | Construct various section arcs (on the ellipsoid), using planes that (a) pass through the two given points and (b) have in-plane vector sampled between the normals of the two points. | |
createGeodesicPath(originalEllipsoid: Ellipsoid, startAngles: LongitudeLatitudeNumber, endAngles: LongitudeLatitudeNumber, density: number | Angle): undefined | GeodesicPathPoint[] Static |
Defined in
- geometry3d/Ellipsoid.ts Line 1023
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.