createRightHandedLocalToWorld MethodStatic
Create a transform containing points or vectors in the given data.
- The xy columns of the transform contain the first points or vectors of the data.
- The z column is perpendicular to that xy plane.
- The calculation favors the first points found. It does not try to get a "best" plane.
createRightHandedLocalToWorld(...params: any[]): undefined | Transform
@returns computed localToWorld frame, or undefined if insufficient data.
Parameter | Type | Description |
---|---|---|
...params | any[] | any number of geometric objects to examine in announce for point/vector data sufficient to construct a frame. If the last argument is a Transform , it is populated with the computed frame and returned. |
Returns - undefined | Transform
computed localToWorld frame, or undefined if insufficient data.
Defined in
- geometry3d/FrameBuilder.ts Line 294
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.