createRightHandedFrame MethodStatic
Create a localToWorld frame for the given data.
- origin is at first point.
- x axis in direction of first nonzero vector present or implied by the input.
- y axis is perpendicular to x and contains (in positive side) the next vector present or implied by the input.
- The calculation favors the first points found. It does not try to get a "best" plane.
createRightHandedFrame(defaultUpVector: Vector3d, ...params: any[]): undefined | Transform
@returns computed localToWorld frame, or undefined if insufficient data.
Parameter | Type | Description |
---|---|---|
defaultUpVector | Vector3d | optional vector to cross with vector0 to create vector1 when it is unknown. The z-column of the returned frame points into the same halfspace as this vector. |
...params | any[] | any number of geometric objects to examine in announce for point/vector data sufficient to construct a frame. If the last argument is a Transform , it is populated with the computed frame and returned. |
Returns - undefined | Transform
computed localToWorld frame, or undefined if insufficient data.
Defined in
- geometry3d/FrameBuilder.ts Line 252
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.