createLocalToWorldTransformInRange MethodStatic
Create the localToWorld transform from a range to axes of its parent coordinate system.
createLocalToWorldTransformInRange(range: Range3d, scaleSelect: AxisScaleSelectAxisScaleSelect.NonUniformRangeContainment, fractionX: number0, fractionY: number0, fractionZ: number0, defaultAxisLength: number1.0, result?: Transform): Transform
@returns localToWorld frame for the range
Parameter | Type | Description |
---|---|---|
range | Range3d | range to inspect |
scaleSelect | AxisScaleSelect | selects size of localToWorld axes. |
fractionX | number | fractional coordinate of frame origin x |
fractionY | number | fractional coordinate of frame origin y |
fractionZ | number | fractional coordinate of frame origin z |
defaultAxisLength | number | if true and any axis length is 0, that axis vector takes this physical length. |
result | Transform | optional pre-allocated Transform to populate and return |
Returns - Transform
localToWorld frame for the range
Defined in
- geometry3d/FrameBuilder.ts Line 346
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.