anglesToUnitNormalRay Method
Compute point (with altitude) at given angles and altitude.
- Never fails for non-singular ellipsoid.
- In the returned ray,
- ray.origin is the point at requested altitude.
- ray.direction is an outward-directed unit vector
anglesToUnitNormalRay(position: LongitudeLatitudeNumber, result?: Ray3d): undefined | Ray3d
Parameter | Type | Description |
---|---|---|
position | LongitudeLatitudeNumber | longitude, latitude, and height |
result | Ray3d |
Returns - undefined | Ray3d
Defined in
- geometry3d/Ellipsoid.ts Line 868
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.