transformRef
GetterReadOnly
Return a (REFERENCE TO) the transform from world space to the mapped sphere space.
- This maps coordinates "relative to the sphere" to world.
- Its inverse maps world coordinates into the sphere space.
- In the sphere space, an xyz (vector from origin) with magnitude equal to 1 is ON the sphere (hence its world image is ON the ellipsoid)
- In the sphere space, an xyz (vector from origin) with magnitude less than 1 is INSIDE the sphere (hence its world image is INSIDE the ellipsoid)
- In the sphere space, an xyz (vector from origin) with magnitude greater than 1 is OUTSIDE the sphere (hence its world image is OUTSIDE the ellipsoid)
transformRef: Transform
Returns - Transform
Defined in
- geometry3d/Ellipsoid.ts Line 196
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.