intersectRay Method
Compute intersections with a ray.
- Return the number of intersections
- Fill any combinations of arrays of
- rayFractions = fractions along the ray
- xyz = xyz intersection coordinates points in space
- thetaPhiRadians = sphere longitude and latitude in radians.
- For each optional array, caller must of course initialize an array (usually empty)
- return 0 if ray length is too small.
intersectRay(ray: Ray3d, rayFractions: number[], xyz: Point3d[], thetaPhiRadians: LongitudeLatitudeNumber[]): number
Parameter | Type | Description |
---|---|---|
ray | Ray3d | |
rayFractions | number[] | |
xyz | Point3d[] | |
thetaPhiRadians | LongitudeLatitudeNumber[] |
Returns - number
Defined in
- geometry3d/Ellipsoid.ts Line 280
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.