appendShape Method
Create and append a new ClipPrimitive to the array given a shape as an array of points. Returns true if successful.
appendShape(shape: Point3d[], zLow?: number, zHigh?: number, transform?: Transform, isMask: booleanfalse, invisible: booleanfalse): boolean
Parameter | Type | Description |
---|---|---|
shape | Point3d[] | |
zLow | number | |
zHigh | number | |
transform | Transform | |
isMask | boolean | |
invisible | boolean |
Returns - boolean
Defined in
- clipping/ClipVector.ts Line 128
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.