selectIntervals01 MethodStatic
Augment the unsortedFractionsArray with 0 and 1
- sort
- test the midpoint of each interval with
clipper.isPointOnOrInside
- pass accepted intervals to
announce(f0,f1,curve)
selectIntervals01(curve: CurvePrimitive, unsortedFractions: GrowableFloat64Array, clipper: Clipper, announce?: AnnounceNumberNumberCurvePrimitive): boolean
Parameter | Type | Description |
---|---|---|
curve | CurvePrimitive | |
unsortedFractions | GrowableFloat64Array | |
clipper | Clipper | |
announce | AnnounceNumberNumberCurvePrimitive |
Returns - boolean
Defined in
- clipping/ClipUtils.ts Line 162
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.