rangeOfIntersectionOfLocalRanges MethodStatic
Compute the range of the intersection between two local (e.g., element-aligned) ranges.
rangeOfIntersectionOfLocalRanges(range0: Range3d, local0ToWorld: Transform, range1: Range3d, local1ToWorld: Transform, result?: Range3d): Range3d
@returns range of the intersection (aligned to world axes). Returns null range if local1ToWorld is singular.
Parameter | Type | Description |
---|---|---|
range0 | Range3d | first range in local coordinates |
local0ToWorld | Transform | placement transform for first range |
range1 | Range3d | second range in local coordinates |
local1ToWorld | Transform | placement transform for second range. Assumed to be invertible. |
result | Range3d | optional pre-allocated range to fill and return |
Returns - Range3d
range of the intersection (aligned to world axes). Returns null range if local1ToWorld is singular.
Defined in
- clipping/ClipUtils.ts Line 721
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.