collectClippedCurves MethodStatic
Compute and return portions of the input curve that are within the clipper.
collectClippedCurves(curve: CurvePrimitive, clipper: Clipper): CurvePrimitive[]
@returns array of clipped curves
Parameter | Type | Description |
---|---|---|
curve | CurvePrimitive | input curve, unmodified |
clipper | Clipper | used to compute the clipped components |
Returns - CurvePrimitive[]
array of clipped curves
Defined in
- clipping/ClipUtils.ts Line 216
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.