announcePolylineClip MethodStatic
Pass line segments from a polyline to the clipper. Resolve the fractional clips to simple points for announcement.
announcePolylineClip(clipper: Clipper, points: Point3d[], announce: (point0: Point3d, point1: Point3d) => void): void
Parameter | Type | Description |
---|---|---|
clipper | Clipper | clipper to call |
points | Point3d[] | polyline whose segments are passed to the clipper |
announce | (point0: Point3d, point1: Point3d) => void | caller's handler for simple point pairs. |
Returns - void
Defined in
- clipping/ClipUtils.ts Line 944
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.