multiplyPlaneByMatrix4d Method
Multiply the ClipPlane's DPoint4d by matrix.
multiplyPlaneByMatrix4d(matrix: Matrix4d, invert: booleantrue, transpose: booleantrue): boolean
@returns false if unable to invert
- Note that if matrixA is applied to all of space, the matrix to send to this method to get a corresponding effect on the plane is the inverse transpose of matrixA
- Callers that will apply the same matrix to many planes should pre-invert the matrix for efficiency.
- Both params default to true to get the full effect of transforming space.
Parameter | Type | Description |
---|---|---|
matrix | Matrix4d | matrix to apply. |
invert | boolean | if true, use in verse of the matrix. |
transpose | boolean | if true, use the transpose of the matrix (or inverse, per invert parameter) |
Returns - boolean
false if unable to invert
- Note that if matrixA is applied to all of space, the matrix to send to this method to get a corresponding effect on the plane is the inverse transpose of matrixA
- Callers that will apply the same matrix to many planes should pre-invert the matrix for efficiency.
- Both params default to true to get the full effect of transforming space.
Defined in
- clipping/ClipPlane.ts Line 521
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.