createCaptureDifference MethodStatic
Create a boolean clipper which performs a difference operation for points "inside primaryClipper
" and
"outside excludedClipper
".
- if
keepInside === true
, accept the "inside" of the difference. - if
keepInside === false
, accept the "outside" of the difference.
createCaptureDifference(primaryClipper: Clipper, excludedClipper: Clipper, keepInside: boolean): Clipper
Parameter | Type | Description |
---|---|---|
primaryClipper | Clipper | any clip object whose output is treated as positive. |
excludedClipper | Clipper | |
keepInside | boolean | flag to select results inside or outside the initial primary minus excludeClipper clippers. |
Returns - Clipper
Defined in
- clipping/BooleanClipFactory.ts Line 75
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.