pointToFraction Method
Compute the projection of the given point
onto the plane of this triangle.
pointToFraction(point: Point3d, result?: TriangleLocationDetail): TriangleLocationDetail
@returns details d of the projection point P = d.world
:
d.isValid
returns true if and only ifthis.normal()
is defined.d.classify
can be used to determine where P lies with respect to the triangle.d.a
is the signed projection distance:P = p + a * this.normal()
.- Visualization can be found at https://www.itwinjs.org/sandbox/SaeedTorabi/BarycentricTriangle
@see fractionToPoint
Parameter | Type | Description |
---|---|---|
point | Point3d | point p to project |
result | TriangleLocationDetail | optional pre-allocated object to fill and return |
Returns - TriangleLocationDetail
details d of the projection point P = d.world
:
d.isValid
returns true if and only ifthis.normal()
is defined.d.classify
can be used to determine where P lies with respect to the triangle.d.a
is the signed projection distance:P = p + a * this.normal()
.- Visualization can be found at https://www.itwinjs.org/sandbox/SaeedTorabi/BarycentricTriangle
Defined in
- geometry3d/BarycentricTriangle.ts Line 286
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.