fractionToPoint Method

Sum the triangle points with given scales.

  • If the scales sum to 1, they are barycentric coordinates, and hence the result point is in the plane of the triangle. If all coordinates are non-negative then the result point is inside the triangle.
  • If the scales do not sum to 1, the point is inside the triangle scaled (by the scale sum) from the origin.

fractionToPoint(b0: number, b1: number, b2: number, result?: Point3d): Point3d

@returns linear combination of the vertices of this triangle

@see pointToFraction

Parameter Type Description
b0 number scale to apply to vertex 0
b1 number scale to apply to vertex 1
b2 number scale to apply to vertex 2
result Point3d optional pre-allocated point to fill and return

Returns - Point3d

linear combination of the vertices of this triangle

Defined in

Last Updated: 28 October, 2024