copyKnots MethodStatic
Return a simple array form of the knots. Optionally replicate the first and last in classic over-clamped manner.
copyKnots(knots: Float64Array | number[], degree: number, includeExtraEndKnot?: boolean, wrapMode?: BSplineWrapMode): number[]
Parameter | Type | Description |
---|---|---|
knots | Float64Array | number[] | |
degree | number | |
includeExtraEndKnot | boolean | |
wrapMode | BSplineWrapMode |
Returns - number[]
Defined in
- bspline/KnotVector.ts Line 470
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.