BSplineWrapMode Enumeration
B-spline curve and surface types in this library are non-periodic. But they can be created from legacy periodic data.
This enumeration lists the possible ways a B-spline object can have been created from legacy periodic data.
Members
Name |
Value |
Description |
None |
|
No conversion performed. |
OpenByAddingControlPoints |
|
The B-spline was opened up by adding degree wrap-around control points to the legacy periodic data. * This is typical of B-splines constructed with maximum (degree - 1) continuity. * Knots are unaffected by this conversion. |
OpenByRemovingKnots |
|
The B-spline was opened up by removing degree extreme knots from the legacy periodic data. * This is typical of rational B-spline curves representing full circles and ellipses. * Poles are unaffected by this conversion. |
Defined in
Last Updated: 19 March, 2025