BSplineCurveOps Namespace
Namespace for collecting curve fit API
Defined in
- bspline/BSplineCurveOps.ts Line 23
BSplineCurveOps Class
A class with static methods for creating B-spline curves.
Methods
Name | Description | |
---|---|---|
constructor(): BSplineCurveOps | ||
createThroughPoints(points: IndexedXYZCollection | Point3d[], order: number): undefined | BSplineCurve3d Static | Greville knot algorithm: alternative to traditional c2 cubic algorithm allowing for any order, but no end conditions or periodicity. | |
createThroughPointsC2Cubic(options: InterpolationCurve3dOptions): undefined | BSplineCurve3d Static | Construct BSplineCurve3d that fit points using the C2 cubic algorithm. |
Defined in
- bspline/BSplineCurveOps.ts Line 23
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.