extendRange Method
Extend a range so in includes the range of this curve
- REMARK: this is based on the poles, not the exact curve. This is generally larger than the true curve range.
extendRange(rangeToExtend: Range3d, transform?: Transform): void
Parameter | Type | Description |
---|---|---|
rangeToExtend | Range3d | |
transform | Transform | transform to apply to points as they are entered into the range. |
Returns - void
Defined in
- bspline/BSplineCurve.ts Line 793
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.