evaluatePointAndDerivativeInSpan Method
Evaluate point and derivative vector at a position given by fractional position within a span.
- The derivative is with respect to the span fraction (NOT scaled to either global fraction or knot)
evaluatePointAndDerivativeInSpan(spanIndex: number, spanFraction: number): Ray3d
Parameter | Type | Description |
---|---|---|
spanIndex | number | |
spanFraction | number |
Returns - Ray3d
Defined in
- bspline/BSplineCurve.ts Line 611
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.