isClosableSurface Method
Test knots and control points to determine if it is possible to close (aka "wrap") the surface in the selected parametric direction.
isClosableSurface(select: UVSelect): BSplineWrapMode
@returns the manner of closing. See BSplineWrapMode
for particulars of each mode.
Parameter | Type | Description |
---|---|---|
select | UVSelect | select U or V direction |
Returns - BSplineWrapMode
the manner of closing. See BSplineWrapMode
for particulars of each mode.
Defined in
- bspline/BSplineSurface.ts Line 544
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.