fractionToRigidFrame Method
evaluate the surface at u and v fractions. Return a (squared, right handed) coordinate frame at that point on the surface.
fractionToRigidFrame(fractionU: number, fractionV: number, result?: Transform): undefined | Transform
Parameter | Type | Description |
---|---|---|
fractionU | number | u parameter |
fractionV | number | v parameter |
result | Transform | undefined if surface derivatives are parallel (or either alone is zero) |
Returns - undefined | Transform
Defined in
- bspline/BSplineSurface.ts Line 284
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.