updateClosestPointByTruePerpendicular Method
Find the closest point within the bezier span, using true perpendicular test (but no endpoint test)
- If closer than previously recorded, update the CurveLocationDetail
- This assumes this bezier is saturated.
updateClosestPointByTruePerpendicular(spacePoint: Point3d, detail: CurveLocationDetail, testAt0: booleanfalse, testAt1: booleanfalse): boolean
@returns true if an updated occurred, false if either (a) no perpendicular projections or (b) perpendiculars were not closer.
Parameter | Type | Description |
---|---|---|
spacePoint | Point3d | point being projected |
detail | CurveLocationDetail | pre-allocated detail to record (evolving) closest point. |
testAt0 | boolean | |
testAt1 | boolean |
Returns - boolean
true if an updated occurred, false if either (a) no perpendicular projections or (b) perpendiculars were not closer.
Defined in
- bspline/BezierCurve3dH.ts Line 224
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.