AkimaCurve3dOptions Class
fitPoints and end condition data for AkimaCurve3d
- This is a "typed object" version of the serializer-friendly AkimaCurve3dProps
- Typical use cases rarely require all parameters, so the constructor does not itemize them as parameters.
Methods
Name | Description | |
---|---|---|
constructor(fitPoints?: Point3d[]): AkimaCurve3dOptions | ||
clone(): AkimaCurve3dOptions | Clone with strongly typed members reduced to simple json. | |
cloneAsAkimaCurve3dProps(): AkimaCurve3dProps | Points that the curve must pass through. | |
areAlmostEqual(dataA: AkimaCurve3dOptions, dataB: AkimaCurve3dOptions): boolean Static | ||
create(source: AkimaCurve3dProps): AkimaCurve3dOptions Static | Clone with strongly typed members reduced to simple json. |
Properties
Name | Type | Description | |
---|---|---|---|
fitPoints | Point3d[] |
Defined in
- bspline/AkimaCurve3d.ts Line 36
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.