alignToGlobe Method
For a geoLocated project, align the view with the global ellipsoid by rotating around the supplied target point such that the view axis points toward the globe center. If the viewing height is below the global transition threshold.
alignToGlobe(target: Point3d, transition?: boolean): ViewStatus
Parameter | Type | Description |
---|---|---|
target | Point3d | The rotation target or pivot point. This point will remain stationary in the view. |
transition | boolean | If this is defined and true then the rotation is scaled by the globalViewTransition This will cause a smooth transition as a view is zoomed out from a specific location to a more global representation. |
Returns - ViewStatus
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.