setupFromFrustum Method
Initialize the origin, extents, and rotation from an existing Frustum This function is commonly used in the implementation of ViewTools as follows:
- Obtain the ViewState's initial frustum.
- Modify the frustum based on user input.
- Update the ViewState to match the modified frustum.
setupFromFrustum(inFrustum: Frustum, opts?: OnViewExtentsError): ViewStatus
@returns Success if the frustum was successfully updated, or an appropriate error code.
Parameter | Type | Description |
---|---|---|
inFrustum | Frustum | |
opts | OnViewExtentsError | for providing onExtentsError |
Returns - ViewStatus
Success if the frustum was successfully updated, or an appropriate error code.
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.