setRotationAboutPoint Method
Set the rotation of this ViewState to the supplied rotation, by rotating it about a point.
setRotationAboutPoint(rotation: Matrix3d, point?: Point3d): void
Parameter | Type | Description |
---|---|---|
rotation | Matrix3d | The new rotation matrix for this ViewState. |
point | Point3d | The point to rotate about. If undefined, use the getTargetPoint. |
Returns - void
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.