findFeatureOverrideProvider Method
Locate the first registered FeatureOverrideProvider matching the supplied criterion.
findFeatureOverrideProvider(predicate: (provider: FeatureOverrideProvider) => boolean): undefined | FeatureOverrideProvider
@returns The first registered provider that matches the predicate, or undefined if no providers match the predicate.
@see - findFeatureOverrideProviderOfType to locate a provider of a specific class.
- addFeatureOverrideProvider to register a provider.
Parameter | Type | Description |
---|---|---|
predicate | (provider: FeatureOverrideProvider) => boolean | A function that will be invoked for each provider currently registered with the viewport, returning true to accept the provider. |
Returns - undefined | FeatureOverrideProvider
The first registered provider that matches the predicate, or undefined if no providers match the predicate.
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.