getStandardRotation MethodStatic
Obtain a Matrix3d corresponding to the specified StandardViewId.
getStandardRotation(id: StandardViewId): Matrix3d
@returns A rotation matrix corresponding to the requested standard view ID, or a "top" view rotation if the input does not correspond to a standard rotation.
Parameter | Type | Description |
---|---|---|
id | StandardViewId | The ID of the desired rotation. |
Returns - Matrix3d
A rotation matrix corresponding to the requested standard view ID, or a "top" view rotation if the input does not correspond to a standard rotation.
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.