LookAtOrthoArgs Interface
Arguments to ViewState3d.lookAt to set up an orthographic view
Extends
Properties
Name | Type | Description | |
---|---|---|---|
lensAngle Readonly | undefined | undefined | ||
targetPoint Readonly | undefined | undefined | ||
viewDirection Readonly | Readonly<WritableXYAndZ> | The direction in which the view should look. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
backDistance Readonly | number | undefined | LookAtArgs | The distance from the eyePoint to the back plane. |
eyePoint Readonly | Readonly<WritableXYAndZ> | LookAtArgs | The new location of the camera/eye. |
frontDistance Readonly | number | undefined | LookAtArgs | The distance from the eyePoint to the front plane. |
newExtents Readonly | Readonly<WritableXAndY> | undefined | LookAtArgs | The new size (width and height) of the view rectangle on the focus plane centered on the targetPoint. |
opts Readonly | OnViewExtentsError | undefined | LookAtArgs | Used for providing onExtentsError. |
upVector Readonly | Vector3d | LookAtArgs | A vector that orients the camera's "up" (view y). |
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.