LookAtArgs Interface
Arguments to ViewState3d.lookAt for either a perspective or orthographic view
Properties
Name | Type | Description | |
---|---|---|---|
backDistance Readonly | number | undefined | The distance from the eyePoint to the back plane. | |
eyePoint Readonly | Readonly<WritableXYAndZ> | The new location of the camera/eye. | |
frontDistance Readonly | number | undefined | The distance from the eyePoint to the front plane. | |
newExtents Readonly | Readonly<WritableXAndY> | undefined | The new size (width and height) of the view rectangle on the focus plane centered on the targetPoint. | |
opts Readonly | OnViewExtentsError | undefined | Used for providing onExtentsError. | |
upVector Readonly | Vector3d | A vector that orients the camera's "up" (view y). |
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.