GetPixelDataWorldPointArgs Interface
Arguments to getPixelDataWorldPoint.
Properties
Name | Type | Description | |
---|---|---|---|
out | Point3d | undefined | If supplied, this point will be modified to store the returned point, instead of allocating a new point. | |
pixels | Pixel.Buffer | The buffer containing the pixel data. | |
preserveModelDisplayTransforms | boolean | undefined | If true, then the world point of a pixel associated with a model will preserve any transforms applied to the model at display time, | |
x | number | The x coordinate of the pixel of interest, in view coordinates. | |
y | number | The y coordinate of the pixel of interest, in view coordinates. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.