getArrowTransform MethodStatic
Compute a transform that will try to orient a 2d shape (like an arrow) to face the camera.
getArrowTransform(vp: Viewport, base: Point3d, direction: Vector3d, sizeInches: number): undefined | Transform
@returns transform or undefined when input direction is almost perpendicular to viewing direction.
@see EditManipulator.HandleUtils.getArrowShape
Parameter | Type | Description |
---|---|---|
vp | Viewport | The viewport to get the rotation from. |
base | Point3d | The world coordinate point to pivot about. |
direction | Vector3d | The world coordinate axis to tilt along. |
sizeInches | number | The transform scale specified in screen inches. |
Returns - undefined | Transform
transform or undefined when input direction is almost perpendicular to viewing direction.
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.