TerrainMeshProviderOptions Interface
Options supplied to createTerrainMeshProvider to construct a TerrainMeshProvider.
Properties
Name | Type | Description | |
---|---|---|---|
dataSource | string | undefined | Optionally identifies a specific terrain data source supplied by the TerrainMeshProvider. | |
exaggeration | number | A scale factor to be applied to the height of the terrain meshes. | |
produceGeometry | boolean | undefined | If true, the provider is being used to collect tiles from the tile tree. | |
wantNormals | boolean | If true, each vertex of the terrain meshes should include a normal vector. | |
wantSkirts | boolean | If true, the meshes should include "skirts" around their edges. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.