createGraphicBuilder Method
Creates a GraphicBuilder for creating a RenderGraphic.
createGraphicBuilder(placement: Transform, type: GraphicType, viewport: Viewport, pickableId?: string): GraphicBuilder
@returns A builder for creating a RenderGraphic of the specified type appropriate for rendering within the specified viewport.
@see - transientIds for obtaining an ID for a pickable decoration.
- createGraphicBuilder.
- Decorator
Parameter | Type | Description |
---|---|---|
placement | Transform | The local-to-world transform in which the builder's geometry is to be defined. |
type | GraphicType | The type of builder to create. |
viewport | Viewport | The viewport in which the resultant RenderGraphic will be rendered. |
pickableId | string | If the decoration is to be pickable, a unique identifier to associate with the resultant RenderGraphic. |
Returns - GraphicBuilder
A builder for creating a RenderGraphic of the specified type appropriate for rendering within the specified viewport.
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.