RealityMeshParamsBuilderOptions Interface
Options used to construct a RealityMeshParamsBuilder.
Properties
Name | Type | Description | |
---|---|---|---|
initialIndexCapacity | number | undefined | If defined, memory for this number of indices will be allocated up-front. | |
initialVertexCapacity | number | undefined | If defined, memory for this number of vertices will be allocated up-front. | |
positionRange | Range3d | A bounding box fully containing the positions of all vertices to be included in the mesh. | |
uvRange | Range2d | undefined | A range fully containing the texture coordinates of all vertices to be included in the mesh. | |
wantNormals | boolean | undefined | If true, normals will be populated. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.