QueryScreenFeaturesOptions Interface
Options specifying how to query for visible Features by reading pixels rendered by a Viewport. This method of determining visibility considers a feature "visible" if it lit up at least one pixel.
@note A pixel that is behind another, transparent pixel is not considered visible.
@see QueryVisibleFeaturesOptions.
Properties
Name | Type | Description | |
---|---|---|---|
includeNonLocatable | boolean | undefined | If true, non-locatable features are considered visible. | |
rect | ViewRect | undefined | If specified, a sub-region of the Viewport to which to constrain the query. | |
source | "screen" | Union discriminator for QueryVisibleFeaturesOptions. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.