constructor Method
Constructor
NotifyMessageDetails(priority: OutputMessagePriority, briefMessage: string | HTMLElement, detailedMessage?: string | HTMLElement, msgType: OutputMessageTypeOutputMessageType.Toast, openAlert: OutputMessageAlertOutputMessageAlert.None): NotifyMessageDetails
Parameter | Type | Description |
---|---|---|
priority | OutputMessagePriority | The priority this message should be accorded by the NotificationManager. |
string | HTMLElement | A short message that conveys the simplest explanation of the issue. | |
string | HTMLElement | An optional comprehensive message that explains the issue in detail and potentially offers a solution. | |
msgType | OutputMessageType | The type of message. Defaults to Toast. |
openAlert | OutputMessageAlert | Whether an alert box should be displayed or not, and if so what kind. |
Returns - NotifyMessageDetails
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.