AccuSnap.Settings Class

Methods

Name Description
constructor(): AccuSnap.Settings    

Properties

Name Type Description
enableFlag boolean Enables snap on cursor motion when true, only snap using Tentative snap when false  
hiliteColdHits boolean Whether the snapped element is also hilited when the snap is not hot  
hotDistanceFactor number How far cursor can be from snap location (relative to snap aperture) and be considered a hot snap  
keypointDivisor number Curve segment divisor used by SnapMode.NearestKeypoint  
searchDistance number Factor applied to locate aperture when snapping is enabled and used to pick snap candidates  
stickyFactor number When moving along an element, affects the affinity for snapping to the same curve as the previous snap  
toolTip boolean Whether to show a tooltip for snap and element locate  
toolTipDelay BeDuration Delay before tooltip appears  

Defined in

Last Updated: 14 November, 2024