updateForScheduleScript Method
Update the Tiles for any TileTrees that use the RenderSchedule.Script hosted by the specified RenderTimeline or DisplayStyle element. This method should be invoked after the host element is updated in the database with a new script, so that any Viewports displaying tiles produced based on the previous version of the script are updated to use the new version of the script.
updateForScheduleScript(scriptSourceElementId: string): Promise<void>
Parameter | Type | Description |
---|---|---|
scriptSourceElementId | string | The Id of the RenderTimeline or DisplayStyle element that hosts the script. |
Returns - Promise
Defined in
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.