getContextRotation MethodStatic
Return a Matrix3d corresponding to the supplied ContextRotationId. A ContextRotationId that corresponds to a standard view, "Top", "Front", etc. will return a Matrix3d that is relative to the current auxCoordSystem when ACS context lock is enabled.
getContextRotation(id: ContextRotationId, vp: Viewport): undefined | Matrix3d
@see acsContextLock
Parameter | Type | Description |
---|---|---|
id | ContextRotationId | |
vp | Viewport |
Returns - undefined | Matrix3d
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.