ElectronApp Class
Frontend of an Electron App.
Methods
Name | Description | |
---|---|---|
constructor(): ElectronApp | ||
callDialog<T extends DialogModuleMethod>(methodName: T, ...args: Parameters<>): Promise<PromiseReturnType<>> Static | Call an asynchronous method in the Electron.Dialog interface from a previously initialized ElectronFrontend. | |
shutdown(): Promise<void> Static | ||
startup(opts?: NativeAppOpts): Promise<void> Static | Start the frontend of an Electron application. |
Properties
Name | Type | Description | |
---|---|---|---|
dialogIpc Static | PickAsyncMethods<Electron.Dialog> | Proxy object for calling methods of Electron.Dialog |
|
isValid Accessor Static ReadOnly | boolean |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.