CutStyleProps Interface
Wire format describing a CutStyle applied to section-cut geometry produced at intersections with a view's ClipVector.
@see cutStyle.
Properties
Name | Type | Description | |
---|---|---|---|
appearance | FeatureAppearanceProps | undefined | If defined, overrides aspects of the cut geometry's symbology. | |
hiddenLine | HiddenLine.SettingsProps | undefined | If defined, overrides the view's Settings when drawing the cut geometry. | |
viewflags | Partial<Mutable<NonFunctionPropertiesOf<ViewFlags>>> | undefined | If defined, overrides aspects of the view's ViewFlags when drawing the cut geometry. |
Defined in
- core/common/src/ClipStyle.ts Line 21
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.