ClipStyleCreateArgs Interface
Arguments supplied to ClipStyle.create.
Properties
Name | Type | Description | |
---|---|---|---|
colorizeIntersection | boolean | undefined | If true , intersection of geometry and clip planes will be colorized |
|
cutStyle | CutStyle | undefined | Controls aspects of how the cut geometry is displayed, if produceCutGeometry is true . |
|
insideColor | RgbColor | undefined | If defined, geometry inside the clip planes will be drawn in this color. | |
intersectionStyle | ClipIntersectionStyle | undefined | Controls the style of the intersection of geometry and clip planes | |
outsideColor | RgbColor | undefined | If defined, geometry outside of the clip planes will be drawn in this color instead of being clipped. | |
produceCutGeometry | boolean | undefined | If true , geometry will be produced at the clip planes in a 3d view. |
Defined in
- core/common/src/ClipStyle.ts Line 177
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.