ClipIntersectionStyle Class
As part of a ClipStyle, describes how to colorize geometry intersecting the clip planes.
@note Edges are highlighted only if ClipIntersectionStyle is true
.
Methods
Name | Description | |
---|---|---|
toJSON(): undefined | ClipIntersectionStyleProps | The JSON representation of this style. | |
create(color?: RgbColor, width?: number): ClipIntersectionStyle Static | Create a highlight from its components. | |
fromJSON(props?: ClipIntersectionStyleProps): ClipIntersectionStyle Static |
Properties
Name | Type | Description | |
---|---|---|---|
color Readonly | RgbColor | Color to apply to intersection of geometry and clip planes, default white | |
defaults Static Readonly | ClipIntersectionStyle | ||
matchesDefaults Accessor ReadOnly | boolean | ||
width Readonly | number | Number of pixels to be considered intersecting the clip plane, default 1 |
Defined in
- core/common/src/ClipStyle.ts Line 118
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.