ThematicDisplaySensor Class
A sensor in world space, used for InverseDistanceWeightedSensors.
Methods
Name | Description | |
---|---|---|
equals(other: ThematicDisplaySensor): boolean | ||
toJSON(): ThematicDisplaySensorProps | ||
fromJSON(json?: ThematicDisplaySensorProps): ThematicDisplaySensor Static |
Properties
Name | Type | Description | |
---|---|---|---|
position | Readonly<Point3d> | The world position of the sensor in X, Y, and Z. | |
value Readonly | number | The value of the sensor used when accessing the thematic gradient texture; expected range is 0 to 1. |
Defined in
- core/common/src/ThematicDisplay.ts Line 295
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.