ThematicDisplayProps Interface
JSON representation of the thematic display setup of a DisplayStyle3d.
Properties
Name | Type | Description | |
---|---|---|---|
axis | XYZProps | undefined | For ThematicDisplayMode.Height, this is the axis along which to apply the thematic gradient in the scene. | |
displayMode | ThematicDisplayMode | undefined | The thematic display mode. | |
gradientSettings | ThematicGradientSettingsProps | undefined | The settings used to create a color gradient applied to the geometry. | |
range | Range1dProps | undefined | The range to use when applying the thematic gradient for height and slope mode. | |
sensorSettings | ThematicDisplaySensorSettingsProps | undefined | For InverseDistanceWeightedSensors, these are the settings that control the sensors. | |
sunDirection | XYZProps | undefined | For HillShade, this is the direction of the sun in world space. |
Defined in
- core/common/src/ThematicDisplay.ts Line 430
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.