ThematicDisplayMode Enumeration
The thematic display mode. This determines how to apply the thematic color gradient to the geometry.
Members
Name | Value | Description |
---|---|---|
Height | The color gradient will be mapped to surface geometry and point clouds based on world height in meters. | |
HillShade | The color gradient will be mapped to surface geometry based on the direction of a sun shining on the surface. @note This display mode does not affect point clouds. |
|
InverseDistanceWeightedSensors | The color gradient will be mapped to surface geometry and point clouds using inverse distance weighting based on world positions and corresponding values from a list of sensors. @note Performance will decrease as more sensors are added. |
|
Slope | The color gradient will be mapped to surface geometry based on the slope of the surface. The slope value is calculated based on the angle between the surface and the axis specified in the associated ThematicDisplay object. @note This display mode does not affect point clouds. |
Defined in
- core/common/src/ThematicDisplay.ts Line 409
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.